Cannot use pymatgen


#1

In ubuntu, I have downloaded pymatgen by ‘pip install pymatgen’
but in python, when I write ‘from pymatgen import MPRester’
It came up with this:
‘usr/local/lib/python2.7/dist-packages/pymatgen/init.py:89: UserWarning:
Pymatgen will drop Py2k support from v2019.1.1. Pls consult the documentation
at https://www.pymatgen.org for more details.
at https://www.pymatgen.org for more details.""")’

What should I do please
Thank you


#2

This is a warning, not an error. You can still use pymatgen. However, I highly recommend you use Python 3 rather than Python 2 (Ubuntu’s default python), as pymatgen will no longer run automated tests against Python 2 starting this January, and thus using pymatgen from Python 2 may not work, or worse, may have unknown bugs.

Best,
Donny